账号  

密码  

您当前位置:信息技术与信息化教学 >> 在线交流 >> >> 交换机与路由器 >> 查看帖子

57

查看

5

回复
主题:单臂路由与直连路由主要配置代码 [收藏主题] 本贴被认定为精华 转到:  
admin 当前在线

196

主题

0

广播

20

粉丝
添加关注
级别:管理员

用户积分:0 分
登录次数:171 次
注册时间:2007/3/30
最后登录:2017/7/19
admin 发表于:2015/12/22 17:18:01   | 只看该作者 查看该作者主题 楼主 

Router>enable

Router#conf t

Router(config)#hostname R01

R01(config)#interface f0/0

R01(config-if)#ip address 192.168.1.10 255.255.255.0

R01(config-if)#no shutdown

R01(config-if)#exit

R01(config)#interface f0/1

R01(config-if)#ip address 192.168.2.10 255.255.255.0

R01(config-if)#no shutdown

R01(config-if)#exit

R01(config) #

Pc1:
192.168.1.1
255.255.255.0
192.168.1.10

Pc2:
192.168.1.2
255.255.255.0
192.168.1.10

Pc3:
192.168.2.1
255.255.255.0
192.168.2.10

Pc3:
192.168.2.2
255.255.255.0
192.168.2.10

 分享到
 344343sssd
  支持(0) | 反对(0) 回到顶部顶端 回到底部底部
admin 当前在线

196

主题

0

广播

20

粉丝
添加关注
级别:管理员

用户积分:0 分
登录次数:171 次
注册时间:2007/3/30
最后登录:2017/7/19
admin 发表于:2015/12/22 17:18:26  Post IP:172.16.124.50 | 只看该作者 查看该作者主题 沙发 

Switch>enable

Switch#configure terminal

Switch(config)#vlan 100

Switch(config-vlan)#name VLAN100

Switch(config-vlan)#exit

Switch(config)#vlan 200

Switch(config-vlan)#name VLAN200

Switch(config-vlan)#exit

Switch(config)#hostname S01

S01(config)#

S01(config)#interface FastEthernet0/1

S01(config-if)#switchport access vlan 100

S01(config-if)# exit

S01(config)# interface FastEthernet0/2

S01(config-if)#switchport access vlan 100

S01(config-if)# exit

S01(config)# interface range FastEthernet0/3-10

S01(config-if)#switchport access vlan 100

S01(config-if)# exit

S01(config)# interface range FastEthernet0/11-20

S01(config-if)#switchport access vlan 200

S01(config-if)# exit

S01(config)#

  支持(0) | 反对(0) 回到顶部顶端 回到底部底部
admin 当前在线

196

主题

0

广播

20

粉丝
添加关注
级别:管理员

用户积分:0 分
登录次数:171 次
注册时间:2007/3/30
最后登录:2017/7/19
admin 发表于:2015/12/22 17:18:45  Post IP:172.16.124.50 | 只看该作者 查看该作者主题 藤椅 

Router>enable

Router#configure terminal

Router(config)#interface FastEthernet0/0

Router(config-if)#ip address 192.168.1.10 255.255.255.0

Router(config-if)#no shutdown

Router(config-if)#exit

Router(config)#

Router(config)#interface FastEthernet0/1

Router(config-if)#ip address 192.168.2.10 255.255.255.0

Router(config-if)#no shutdown

Router(config-if)#exit

Router(config)#



  支持(0) | 反对(0) 回到顶部顶端 回到底部底部
admin 当前在线

196

主题

0

广播

20

粉丝
添加关注
级别:管理员

用户积分:0 分
登录次数:171 次
注册时间:2007/3/30
最后登录:2017/7/19
admin 发表于:2015/12/22 17:19:04  Post IP:172.16.124.50 | 只看该作者 查看该作者主题 板凳 

单臂路由主要代码:

Switch(config)# interface FastEthernet0/24

Switch(config-if)#switchport mode trunk

Switch(config-if)#switchport trunk allowed vlan all

Switch(config-if)#no shutdown

Switch(config-if)#exit

Switch(config)#

Router(config)#inter f0/0.1

Router(config-subif)#ip address 192.168.1.10 255.255.255.0

Router(config-subif)#encap dot1q

100

Router(config-subif)#no shutdown

Router(config-subif)#exit

Router(config)#inter f0/0.2

Router(config-subif)#ip address 192.168.2.10 255.255.255.0

Router(config-subif)#encap dot1q

200

Router(config-subif)#no shutdown

Router(config-subif)#exit

Router(config)#

  支持(0) | 反对(0) 回到顶部顶端 回到底部底部
admin 当前在线

196

主题

0

广播

20

粉丝
添加关注
级别:管理员

用户积分:0 分
登录次数:171 次
注册时间:2007/3/30
最后登录:2017/7/19
admin 发表于:2015/12/22 17:20:13  Post IP:172.16.124.50 | 只看该作者 查看该作者主题 报纸 

单臂路由主要代码:

Switch(config)# interface FastEthernet0/24

Switch(config-if)#switchport mode trunk

Switch(config-if)#switchport trunk allowed vlan all

Switch(config-if)#no shutdown

Switch(config-if)#exit

Switch(config)#

Router(config)#inter f0/0.1

Router(config-subif)#ip address 192.168.1.10 255.255.255.0

Router(config-subif)#encap dot1q

100

Router(config-subif)#no shutdown

Router(config-subif)#exit

Router(config)#inter f0/0.2

Router(config-subif)#ip address 192.168.2.10 255.255.255.0

Router(config-subif)#encap dot1q

200

Router(config-subif)#no shutdown

Router(config-subif)#exit

Router(config)#

  支持(0) | 反对(0) 回到顶部顶端 回到底部底部
cxp07013042 当前离线

35

主题

4

广播

1

粉丝
添加关注
级别:学前班

用户积分:21 分
登录次数:19 次
注册时间:2016/3/2
最后登录:2016/6/1
cxp07013042 发表于:2016/3/2 11:57:46  Post IP:172.24.135.149 | 只看该作者 查看该作者主题 地板 
表示看不懂不是我
  支持(0) | 反对(0) 回到顶部顶端 回到底部底部
<上一主题 | 下一主题 >
河西学院信息技术与传媒学院 信息技术与信息化教学 版权所有

©copyright 2015. All rights reserved.

页面执行0.25000秒